• Archives

  • Categories


  • wallaceadngromit.net

  • Partimus

  • Secular Humanism

  • Debian

  • Ubuntu Women

  • Xubuntu

  • OpenStack

Taming Lubuntu on my PowerBook G4

About a year ago I adopted a MacBook Pro and a PowerBook G4. The MacBook Pro now happily runs OSX, when we turn it on (mostly MJ uses it for photo processing). In spite of being quite the nice machine for 2004, the poor PowerBook G4 had been long abandoned by Apple due to it’s PPC nature and this made me quite sad. My plan had been to load it up with Lubuntu, use it here and there and help out with ISO testing. Then 2013 happened. New job! Wedding! I was much busier than anticipated, after loading up Lubuntu 12.04 on the PowerBook I didn’t have a whole lot of time to spend with it.

This week I pulled my PowerBook G4 off the shelf and loaded up Lubuntu 13.10. I quickly learned that it’s one of the more finicky PowerBooks when it comes to sound, and my initial cleverness during install led me to have some graphical pain. Here’s what I had to fix:

First up, when I loaded up the Lubuntu LiveCD the graphics were a mess. The installer advised that if problems existed you could try passing the LiveCD a video option of “video=ofonly” which I did and then happily ran the installer. Unfortunately this later caused my installed system to lock up pretty quickly after booting it. Sad. I got my clue to what I should be using for video via this page. I made a quick change to /etc/yaboot.conf to swap out the video option:

append="quiet splash video=radeonfb:1024x786-32@60"

Ran `sudo ybin` and rebooted. Voila! No more crashes.

Now wifi.

elizabeth@r2g4:~$ lspci | grep Network
0001:10:12.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)

That’s a job for the firmware-b43-installer package. Easy enough. I now had wifi!

The trickiest part of this install was audio. It turns out that most PowerBook G4s have sound working out of the box, but I got unlucky.

elizabeth@r2g4:~$ alsamixer
cannot open mixer: No such file or directory

And no /proc/asound at all. That won’t do!

Back to the wiki, PowerPC FAQ: Why do I have no sound?

After a whole lot of trial and error, I learned that this bug was indeed my culprit. I had to remove the snd_aoa entries from /etc/modprobe.d/blacklist.local.conf and then edit: /etc/modules

Removing: snd_powerbook

And adding: snd_aoa_i2sbus

I had manually rmmod & modprobed the modules to test and was finally able to run alsamixer to adjust the volume settings. Then a reboot to confirm all was well. Hooray, sound!

I was pretty happy at this point, but I had to go a bit further, the backlight for the keyboard wasn’t working! The island-style keyboards are the bane of my existence, I hate that all laptops have gone to them. But this old PowerBook G4? Beautiful keyboard, aside from the awkward placing of the alt key, it’s a pleasure to type on.

Backlit functionality would be the icing on the cake, fortunately for me it was as easy as:

sudo modprobe i2c-dev

This made my Mac hotkeys work and the keyboard backlight. Winner! I added the module for /etc/modules for persistence.

The system isn’t exactly zippy, but with a gig of ram it’s quite usable, particularly for writing. I’m happy to learn that sensitivity problems I encountered with the touchpad in 12.04 have been resolved and I’m looking forward to loading it up with tests this cycle so maybe less manual labor will be required for the 14.04 release.

4 Comments

 




XHTML: You can use these tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>